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Введение

Получив своё развитие в середине ХХ в., СВЧ-микроэлектроника стала одной из основных отраслей электроники. Развитие твердотельных СВЧ-приборов ограничивается тем, что при их проектировании необходимо учитывать большое количество факторов, например, малые размеры узлов, концентрации сильных полей в малых объемах, наличие цепей паразитной связи, взаимодействие близко расположенных элементов, трудности отвода тепла, требования к точности изготовления и однородности материалов.

Для определения параметров несимметричного полосно-пропуска-ющего микрополоскового фильтра необходимо решать граничную задачу электродинамики. Однако даже для регулярных микрополосковых линий, не говоря уже о сложных СВЧ-узлах, граничные поверхности имеют сложную форму и волновые уравнения разрешить не удается. К настоящему времени строгой теории ни одного микрополоскового устройства не существует. Приближенные теории всегда нуждаются в экспериментальной проверке. Поэтому несимметричные полосно-пропускающие микрополосковые фильтры приходится испытывать и настраивать экспериментально, что приводит к тратам значительных материальных ресурсов или к необходимости применения программ моделирования СВЧ-элементов. Среди систем автоматизированного проектирования радиоэлектронных устройств наибольшее распространие находит среда Advanced Design System, в которой возможно проектирование различного рода СВЧ-устройств. Использование этой среды проектирования позволяет значительно сократить время на разработку радиоэлектронной аппаратуры.
Данное учебно-методическое пособие содержит описание примера пошагового проектирования несимметричного полосно-пропускающего микрополоскового фильтра в среде Advanced Design System. Кроме того, в пособии приведены сведения об основах использования инструмента Layout, позволяющего разрабатывать топологию указанного микрополоскового фильтра.
1. Запуск программы Advanced Design System
Рассмотрим последовательность проектирования несимметричного полосно-пропускающего микрополоскового фильтра в среде Advanced Design System. Чтобы начать работу с программой Agilent Advanced Design System (ADS), в операционной системе Microsoft Windows® нажмите кнопку Пуск, в появившемся меню выберите пункт «Программы», а затем выберите группу программ соответствующей версии программы Advanced Design System. В появившемся списке выберите пункт Advanced Design System (рис. 1).
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Рис. 1. Последовательность выбора пункта Advanced Design System
После выбора пункта Advanced Design System появится главное окно среды моделирования, показанное на рисунке 2.
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Рис. 2. Главное окно программы Agilent Advanced Design System

1.1. Создание нового проекта

Для создания нового проекта выполните следующие действия:

1. В главном окне программы Advanced Design System на панели инструментов Standard (Стандартные) нажмите кнопку [image: image4.png]


 или выберите пункт меню File → New Project (Файл → Новый проект).

[image: image5.png]gEexCREBE =&

KHONKA 17151 CO3anus
HOBOTO MpPoEKTa




Рис. 3. Панель инструментов Standard (Стандартные)
2. После отображения диалогового окна в поле Name (Название) введите название проекта \users\default\layout.
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Рис. 4. Диалоговое окно ввода параметров размещения проекта

Примечание. Выпадающий список Project Technology Files (Технологические файлы проекта) содержит настройки для различного рода элементов, например для сегмента микрополосковой линии. Выбранное значение в выпадающем списке Project Technology Files (Технологические файлы проекта) используется также при разработке топологии. Кнопка Browse (Обзор) позволяет создавать папки проекта в необходимом месте на жестком диске компьютера. 

3. Для продолжения нажмите кнопку OK.

1.2. Области просмотра File Brower (Обозреватель файлов) 
 и Project Hierarchy (Иерархия проекта)
На рисунке 5 главное окно программы содержит область просмотра File Browser (Обозреватель файлов), в которой отображаются каталоги проекта. Обратите внимание на то, что подкаталоги (data (данные), networks (цепи) и т.д.) создаются автоматически. Все файлы схем находятся в каталоге networks (цепи).
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Рис. 5. Области просмотра File Brower (Обозреватель файлов) 
и Project Hierarchy (Иерархия проекта) в главном окне

2. Создание макета схемы
1. В  главном окне программы Advanced Design System щелкните курсором мыши по значку New Schematic Window (Новое окно схемы) или выберите пункт меню Window → New Schematic Window (Окно → Новое окно схемы). Сразу после этого отобразится окно Schematic (Схема).
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Рис. 6. Окно Schematic (Схема) с палитрой компонентов TLines-Microstrip
2. Далее необходимо сохранить макет схемы. Обратите внимание на то, что в заголовке главного окна содержится название проекта и название схемы (untitled2) с порядковым номером (1, 2, 3 и т.д.) открытого окна схемы. Для того чтобы переименовать схему, в главном меню выберите File → Save As (Файл → Сохранить как) и в соответствующее поле (см. рис. 7) введите новое имя, например microstrip_filter, а затем нажмите кнопку Save (Сохранить). Новая схема будет сохранена в каталог networks проекта layout.
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Рис. 7. Диалоговое окно сохранения макета схемы
 SHAPE  \* MERGEFORMAT 
3. В списке Components Palette (Палитры компонентов) выберите палитру TLines-Mcrostrip, в которой содержатся элементы, необходимые для построения схемы полосно-пропускающего микрополоскового фильтра.
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Рис. 8. Список Components Palette (Палитры компонентов)
3. Установка значений параметров 
     шаблона схемы
1. В окне макета схемы выберите пункт меню Window → Layout (Окно → Шаблон). После этого откроется соответствующее окно шаблона  (рис. 9).
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Рис. 9. Окно шаблона проекта
2. В окне шаблона выберите Options → Preferences (Параметры → Глобальные настройки). Далее перейдите на вкладку Grid/Snap (Сетка/Привязка) и установите следующие значения для осей координат X и Y: Grid Snap distance (Порог сетки выравнивания) = 1, Minor Grid (Вспомогательная сетка) = 20, Major Grid (Основная сетка) = 200, как показано на рисунке 10. После этого нажмите кнопку Apply (Применить).
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Рис. 10. Вкладка Grid/Snap с параметрами настройки привязки к сетке
Примечание. В единицах мил (1 мил = 0,001 дюйма) деления основной сетки теперь равны 0,2 дюйма, т.е. 1 × 200 = 200 мил или 0,2 дюйма. Шаг сетки можно установить равным любому необходимому значению. Можно также установить привязку к вершине угла или к краю какого-либо элемента схемы.

3. Обратите внимание на панель инструментов в окне шаблона, которая содержит кнопки (рис. 11) тех же самых значков привязки, используемых во время рисования или размещения объектов на макете.
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Рис. 11. Кнопки панели инструментов окна шаблона, 
используемые для задания вариантов привязки элементов схемы
4. В диалоговом окне Preferences (Глобальные параметры) просмотрите другие вкладки в ознакомительных целях. На данном этапе проектирования фильтра изменение других настроек не требуется, поэтому нажмите кнопку OK, чтобы закрыть текущее диалоговое окно.

4. Размещение элементов фильтра 
    в окне макета схемы
1. Перейдите в окно макета схемы. Нажав кнопку [image: image14.png]


, разместите на макете схемы элемент VAR и задайте переменные (рис. 12) со следующими значениями: W1 = 25 мил, L1 = 250 мил, S1 = 25 мил и S2 = 25 мил.
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а)                                                                          б)

Рис. 12. Окно задания переменных (а) и элемент VAR на макете схемы (б)
2. Из палитры TLines-Microstrip вставьте две микрополосковые связанные линии (элемент MCFIL) и измените значения их параметров на ранее заданные значения VAR (рис. 13). Параметр Msub1 будем пока игнорировать.
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Рис. 13. Элементы MCFIL на макете схемы
3. С помощью кнопки [image: image18.png]


 добавьте на макет элемент Port и соедините элементы схемы (используйте кнопку [image: image19.png]


), чтобы она приобрела вид, показанный на рисунке 14:
[image: image20.png]-

Port
P1+
Num=1 C
CLin1
: CLin2
Vo] VAR i
L=L1

Subst="MSub1"
W=w1

s=
=
$2=25 mil




Рис. 14. Вид схемы после добавления элемента Port 
и соединения её элементов
4.Сгенерируйте шаблон, выбрав пункт меню Layout → Generate/Update Layout (Шаблон → Генерировать/Обновить шаблон). После этого отобразится диалоговое окно на рисунке 15.
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Рис. 15. Окно, содержащее параметры генерируемого шаблона

5. Нажмите кнопку OK. В окне макета (рис. 16) будут отображаться сегменты микрополосковой линии (Clin1 и Clin2) и стрелка (P1), соответствующая входному порту.
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Рис. 16. Окно шаблона элементов схемы на рисунке 14
6. Завершите построение фильтра. Для этого в окне шаблона выберите пункт меню Select → Select All (Выбрать → Выбрать всё). Используя команды копирования, вставки и поворота выбранных компонентов, создайте шаблон микрополоскового фильтра, показанный на рисунке 17.
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Рис. 17. Шаблон микрополоскового фильтра
7. Сохраните шаблон, а затем выберите пункт меню Schematic→  Generate/Update Schematic (Схема → Сгенерировать/Обновить схему) и проследите за обновлением макета схемы. Должен быть получен макет схемы, показанный на рисунке 18.
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Рис. 18. Макет схемы микрополоскового фильтра
8. Сохраните шаблон схемы под названием microstrip_filter, создайте новый макет схемы и сохраните его под названием bp_filter.
9. Нажав на панели инструментов кнопку [image: image25.png]


, вставьте компонент ms_filter (рис. 19).
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Рис. 19. Окно выбора компонентов библиотеки
10. Соберите схему, показанную на рисунке 20, добавив элемент MSUB из палитры TLines-Microstrip, а оконечные элементы Term и контроллер моделирования S-параметров из палитры Simulation-S_Param. Элемент Msub является описанием подложки.
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Рис. 20. Схема для моделирования частотных характеристик 
микрополоскового фильтра
Примечание. Выбрав элемент microstrip_filter на схеме и нажав кнопку [image: image28.png][



, можно просмотреть структуру выбранного элемента. Она будет соответствовать шаблону схемы, показанной на рисунке 18.
5. Настройка и запуск моделирования 
частотных характеристик ПОЛОСНО-
пропускающего микрополоскового фильтра
1. Для настройки частотного диапазона моделирования дважды щелкните курсором мыши по элементу S-parameter simulation controller (Контроллер моделирования S-параметров) на исследуемой схеме. После отображения диалогового окна на вкладке Frequency (Частота) введите значения начальной частоты, конечной частоты и шаг ее изменения, а затем нажмите кнопку Apply (Применить). 

Для моделирования будем использовать следующие значения частоты (рис. 21):

· начальная частота (поле Start): 4 ГГц;

· конечная частота (поле Stop): 8 ГГц;

· шаг изменения частоты (поле Step-Size): 20 МГц.
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Рис. 21. Диалоговое окно установки частотного диапазона 
моделирования и шага изменения частоты
2. Для закрытия диалогового окна нажмите кнопку OK.

3. Чтобы запустить процесс моделирования, на панели инструментов нажмите кнопку Simulate (Моделировать), содержащую изображение шестеренки [image: image30.png]


. Результаты моделирования всегда записываются в текущий набор данных, который был задан ранее. В появившемся окне Status (Состояние) должно содержаться сообщение (см. рис. 22), информирующее о результатах моделирования. Запись «SP1» (см. рис. 22) относится к контроллеру моделирования S-параметров и к его настройкам. При отсутствии ошибок сообщение будет информировать об окончании моделирования и записи набора данных в каталог data (данные) текущего проекта.
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Рис. 22. Диалоговое окно Status (Состояние)
7. После ознакомления с сообщением закройте окно Status (Состояние). Отображение окна состояния может быть восстановлено путем выбора пункта меню Window → Restore Status (Окно → Восстановить окно состояния).
6. Отображение результатов моделирования
1. Откройте окно отображения данных в главном окне программы ADS или в окне схемы, щелкнув по значку Data Display (Отображение данных).

2. После открытия окна Data Display (Отображение даных) в выпадающем списке будет отображаться название набора данных bp_filter     (рис. 23).

[image: image32.png]



Рис. 23. Окно Data Display (Отображение данных)
3. Для создания графика щелкните по значку Rectangular Plot (Прямоугольный график) [image: image33.png]


 и переместите курсор, щелкнув им в месте, где необходимо разместить график. При появлении нижеследующего диалогового окна (рис. 24) выберите тип данных S(2,1) и нажмите кнопку Add (Добавить).
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Рис. 24. Диалоговое окно выбора отображаемых параметров

4. В диалоговом окне на рисунке 25а необходимо будет указать тип отображаемых данных. Выберите значение dB (дБ) и нажмите кнопку OK. На графике (см. рис. 25б) должен отобразиться соответствующий отклик полосно-пропускающего фильтра.
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Рис. 25. Диалоговое окно (а) выбора масштаба оси графика 
и частотная зависимость (б) параметра S21 
для полосно-пропускающего микрополоскового фильтра

7. Изменение частотной характеристики фильтра
Попытаемся изменить частотную характеристику параметра S21 так, чтобы была только одна центральная частота 6 ГГц, и измерим полосу пропускания по уровню –30 дБ. Для этого потребуется изменить взаимное расположение и размеры микрополосковых линий, которые были указаны в начале создания проекта для полосно-пропускающего фильтра. Выполните нижеследующую последовательность действий.

1. Выберите шаблон схемы bp_filter, а затем на панели инструментов нажмите кнопку настройки параметров схемы [image: image37.png]=



. Появится окно настройки параметров, показанное на рисунке 26:
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Рис. 26. Окно настройки параметров

2. В окне макета схемы наведите курсор мыши и перекрещивающиеся линии на элемент microstrip_filter (рис. 27), а затем в контекстном меню выберите пункт Push Into Hierarchy (Перейти к иерархии).
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Рис. 27. Расположение курсора мыши на элементе microstrip_filter
3. После выбора пункта контекстного меню будет выполнен переход к макету схемы microstrip_filter. Выберите курсором мыши все четыре параметра элемента VAR (W1, L1, S1, S2), чтобы получить следующее окно настройки параметров.
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Рис. 28. Окно настройки с четырьмя параметрами ​– W1, L1, S1 и S2
Примечание. В поле Value приведено текущее значение параметра, а в полях Max и Min – его максимальное и минимальное значение соответственно. С помощью кнопок [image: image41.png]


 и [image: image42.png]


 текущее значение может быть уменьшено или учеличено с шагом, указанным в поле Step.
4. В окне Data Display (Отображение данных) отобразите амплитудно-частотную характеристику параметра S21 так, как указано в разделе 7 данного учебно-методического пособия.
5. В окне настройки параметров в выпадающем списке Simulate (Моделировать) выберите пункт While Slider Moves (Во время перемещения ползунка). Это позволит отображать результат моделирования амплитудно-частотной характеристики параметра S21 сразу после изменения одного из вышеуказанных параметров.

6. Измените значения параметров так, чтобы получить амплитудно-частотную характеристику параметра S21, показанную на рисунке 29.
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Рис. 29. Амплитудно-частотные характеристики параметра S21 
с центральной частотой 6 ГГц
5. Измерим полосу пропускания проектируемого фильтра по уровню        –30 дБ. Для этого понадобится установить на кривой два маркера – слева и справа от центральной частоты. Выберите пункт меню Marker → New (Маркер → Новый). Затем выберите кривую графика и щелкните курсором мыши в месте, где необходимо установить маркер. После установки маркер можно перемещать с помощью курсора мыши или клавиш со стрелками на клавиатуре. Кроме того, текст маркера можно также перемещать в необходимое положение. Маркеры можно удалять или устанавливать дополнительные.
6. Как видно из рисунка 30, полоса пропускания спроектированного полосно-пропускающего микрополоскового фильтра по уровню –30 дБ составила примерно от 5,78 до 6,26 ГГц.
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Рис. 30. Измерение полосы пропускания с помощью маркеров
7. Сделанные нами изменения параметров также внесли изменения и в геометрию нашего микрополоскового фильтра. Чтобы увидеть, как теперь выглядит шаблон, в окне макета схемы выберите пункт меню Layout → Generate/Update Layout (Шаблон → Генерировать/Обновить шаблон). Новый шаблон микрополоскового фильтра будет иметь следующий вид:
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Рис. 31. Окончательный вид шаблона полосно-пропускающего 
мирополоскового фильтра с центральной частотой 6 ГГц
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